Os tutoriais e templates aqui apresentados são voltados para os Modelos de layout (lançados em 2006). A eficácia das dicas aqui apresentadas não foram testadas nos novos modelos de templates do Blogger (2010).

28 março 2011

Problemas com o link 'Postagens Anteriores' erro bX-67oaj1

Hoje pela manhã recebi um email de uma pessoa que usa o Template Oggi reportando-me um erro ao clicar no link 'Postagens Anteriores': o resumo de postagem não funcionava nesta página. Aqui mesmo no TNB ocorria o mesmo problema. No twitter, alguns relataram que, ao clicar no mesmo link, aparece erro bX-67oaj1 e não é possível visualizar os posts anteriores. Encontrei na página de ajuda do Blogger (em inglês) uma solução postada pelo usuário Dmusicteam  que resolveu o problema, pelo menos aqui no TNB.

Se você usa uma imagem no ligar dos links 'Postagens Anteriores' e 'Postagens Recentes':

1- Clique em Editar HTML;
2- Clique em Expandir Modelo de Widget;
3- Procure pelos trechos:

<a class='blog-pager-newer-link' expr:href='data:newerPageUrl' expr:id='data:widget.instanceId + &quot;_blog-pager-newer-link&quot;' expr:title='data:newerPageTitle' target='_blank'> <img src='url da sua imagem'></a>
<a class='blog-pager-older-link' expr:href='data:olderPageUrl' expr:id='data:widget.
instanceId + &quot;_blog-pager-older-link&quot;' expr:title='data:olderPageTitle'> <img src='url da sua imagem'> </a> 
e substitua por:

<a expr:href='data:newerPageUrl' expr:title='data:newerPageTitle' id='blog-pager-newer-link'><img src='url da sua imagem'/></a>
 e
<a expr:href='data:olderPageUrl' expr:title='data:olderPageTitle' id='blog-pager-older-link'><img src='url da sua imagem'/> </a> 

Se você não utiliza imagem, substitua os trechos:

<a class='blog-pager-newer-link' expr:href='data:newerPageUrl' expr:id='data:widget.instanceId + &quot;_blog-pager-newer-link&quot;' expr:title='data:newerPageTitle' target='_blank'><data:newerPageTitle/></a>
 e
<a class='blog-pager-older-link' expr:href='data:olderPageUrl' expr:id='data:widget.instanceId + &quot;_blog-pager-older-link&quot;' expr:title='data:olderPageTitle'><data:olderPageTitle/></a> 
Por estes códigos:
<a expr:href='data:newerPageUrl' expr:title='data:newerPageTitle' id='blog-pager-newer-link'><data:newerPageTitle/></a>
e
<a expr:href='data:olderPageUrl' expr:title='data:olderPageTitle' id='blog-pager-older-link'><data:olderPageTitle/></a>

Importante!
Antes de salvar as mudanças, clique em Visualizar e no link (ou imagem) 'Postagens Anteriores, para ver se tudo voltou ao normal. Só então salve. Se ocorrer algum problema, clique em 'Limpar Edições".

Artigos Relacionados

46 comentários:

Max Martins disse...

Ariane,

Muito obrigado por compartilhar e pela atenção.
Segui o tutorial e tudo está funcionando normalmente.

Forte abraço!

Up! My Blog disse...

Oi Ariane!!!
Gosto muito do seu blog, suas dicas me ajudam bastante!!!
Gostaria de saber se você faz parcerias e, caso faça, como é o seu sistema.
Tenho um blog, que não é muito famoso, mas tem visitas regulares, veja: http://up-myblog.blogspot.com

Mil Sweetkisses.

Sir. Alfieri disse...

OPA VALEU ARIANE!!! ACHO QUE ACONTECEU COM TODO MUNDO ISSO HOJE!!!

OBRIGADÃO!!! RESOLVEU AQUI

www.OvelhasVerdes.com

Mano disse...

Ariane, muito obrigado! Passei o dia procurando uma solução para esse problema e só fui encontrar aqui! :)

Abraço!

Lindemberg Rocha disse...

Deu certo! Obrigado Ariane,

Fiquei feliz pela forma como atendeu o meu (nosso) pedido. Você realmente é muito atenciosa e dedicada como blogueira, parabéns! Sou seu leitor há alguns anos e, agora, mais do que nunca.

Att
Lindemberg

Fatinha disse...

Ariane, Obrigada!!
Voce sempre atualizada e nos ajudando!!
Deu certissimo aqui.
Estou aliviada!!!

Beijos

Eduardo Chaves disse...

Obrigado Ariane pela luz no fim do túnel.

Na minha opinião você e Clau do Mundo blogger são as melhores Blogueiras no Brasil!!!

Valeu um abraço,
Eduardo Chaves do VigilanteTemNotícias.com.br

OlharesCuriosos disse...

Muito Obrigado. Sou um usuário português e já andava pesquisando a solução deste problema desde domingo. Vim encontrar neste blog muito interessante. Fiqui fã...

Fabiano Santos disse...

Me salvou!

petit-pois! disse...

Gente... me ajudem por favor! Comigo não deu certo. Eu não achei nenhum desses trechos no meu html e o meu blog continua com erros. Obrigada.

AKware disse...

Ariane, muito grato realmente pela sua dica, pois ja num sabia mais o que fazer, " ja estava pensando em mudar de Templaste " na verdade num queria porque o templaste que uso e muito trabalhoso em mexer , nos codigo html, pois vire e mexe sempre estou modificando algumas coisa no templaste, por isso num queria perder o templaste, agradeço muito sua atenção e dedicação, a nos bloguista, segue meu blog pra vc conhecer e me dar umas dicas, http://www.chatmesadebar.blogspot.com/ " beijos Ariane grato por tudo"

RelliK disse...

Valew cara, ajudou muito, muito msm, só que fiquei um tempinho arrumando o se html ae, que ta um pk errado (muito pouco apenas um ' )
src=''url da sua imagem'/>

No url da sua imagem ta com ''url da sua imagem'
em vez de 'url da sua imagem'
Não estou querendo ensinar você, estou apenas relatando um erro :)
vlw kra, blog que vc ajudou http://IGORELLIK.blogspot.com

Ariane disse...

Rellik te agradeço por me mostrar o erro, já arrumei! :)

Mari disse...

Ow Ariane... me ajuda please! Comigo não deu certo... Eu não achei os trechos que vc indicou na dica. Desculpa perturbar mais uma vez, mas é que eu não queria mudar de template. Demorei tanto até achar esse que me agrada. Obrigada.

LuKiNhA® Design ©2011 disse...

nossa salvou minha vida...valeu msm

johnathan kennedy (: disse...

thanks por compartilhar :D

Jota disse...

Ajudou muiiiito...
Obrigado!

Anônimo disse...

Valeu mesmo !

Sayonara disse...

ola! Obgda valeu! Deu certo.Bjs

Bruno Oliveira disse...

Eu estou com esse problema e não consegui resolver. Aqui esses dois códigos que seriam os mudados aparecem 2 vezes cada um. Sendo o primeiro que voce falou tem isso no final de diferente do meu, na verdade é só essa parte a mais no seu que não tem no meu:

target='_blank'>

Enfim, fiz de tudo, segui as instruções, substitui todos ou apenas os primeiros e etc. E a única coisa que acontece é que só volta ao normal a próxima página "postagens antigas", a da que seria a página 2 do blog, mas o resto, continua com o mesmo erro, da página 3 em diante.

Putz, to quebrando cabeça em uma coisa que não sei mexer muito, se voce ou alguém pudesse me ajudar eu iria agradecer muito.

Bruno Oliveira disse...

O "leia mais" não funciona nas outas páginas, apenas na inicial, foi de uma hora pra outra que aconteceu, junto com esse erro bX-67oaj1. Na primeira página do blog aparece o resumo dos posts e o "leia mais", da segunda e mdiante aparecem os posts com abertos normais, um por cima do outro. Alguém por favor me dá uma luz?

Ingrid disse...

Oi Ariane, eu gostei muito do seu blog, o conteúdo é muito bom.
Mas será que você pode me ajudar?
Eu procurei os códigos, mas a caixinha de pesquisa não encontrou. Os códigos estão exatamente do jeito que você escreveu lá no html?
Meu blog ainda está com o erro! :(
http://lookbloguie.blogspot.com/

Dá uma ajudinha aí por favor!

rubS disse...

Muito bom. Obrigado pela solução.

Parece-me que você é web-designer. Então, para retribuir a contribuição, deixo uma dica minha para melhorar seus layouts e torná-los ainda mais atrativos: usar CSS Transitions (http://rubsphp.blogspot.com/2011/03/css-transitions.html).

Até.

Marcos disse...

valeu cara, to seguindo e favoritei!

Urasam Urashima disse...

OI, eu gostaria de saber como faço para colocar postagens relacionadas no Template Oggi. Ele é muito bom, mas eu queria conseguir colocar isso.

Storm_TR disse...

Decidi comentar porque estava com esse problema mas depois encontrei este blog que me deu a solução.
Desde já obrigado continuem com o bom trabalho.

MacGyver (Anderson Lima) disse...

obrigado, moça, rodou certinho!

Blog do Lucas disse...

Não sei nem como lhe agradeçer!

Quero apenas informar que de alguma forma vc faz pessoas felizes... realizadas...com seu trabalho vendo saidas onde não há pois passei a madrugada toda tentando resolver esse problema e não consegui!
Brigado de coração!
Lucas Porto

Moosh Massacre disse...

sensacional! valeu mesmo *-*

Jorge(Overdarksider)™ disse...

Muito obrigado, graças a você meu site continua bombando como nunca!
Abraço!

Nati disse...

Não foi possível salvar o modelo

Corrija o erro abaixo e envie o seu modelo novamente.
Não foi possível analisar o seu modelo, pois sua formatação é inadequada. Certifique-se de que todos os elementos XML estão fechados adequadamente.
Mensagem de erro em XML: The element type "span" must be terminated by the matching end-tag "".


Deu isso no meu! e agora?

MOCAM disse...

Graças a Deus e a este bendito post, consegui resolver meu problema. Vida longa ao site de vocês!

Abraços,

MOCAM

RelliK disse...

Eae Ariane, agradeço por ler o meu comentario e arrumar, se possivel visite meu blog, vlw, vc me ajudou denovo, pois mudei o design do blog e agora precisei denov, VLW

Matheus Basílio disse...

Você é sensacional! Funcionou perfeitamente.
Obrigado.

Anderson disse...

Este erro imcomodou muita gente q usa Custom Templates como eu. Com este Fix tudo voltou a Funcionar Perfeitamente .

Obrigado .

WAL disse...

A MUITO TEMPO NÃO DAVA UMA NOTA " 10 " A UM BLOG OU SITE" PELAS RESPOSTAS OU TUTORIAIS " , MAIS VC ESTA DE PARABENS .


UM MARAVILHOSA DIA .

O BLOG E NOTA 1000000000000000

Guilherme Vezaro disse...

obrigado, precisava urgente disso!

Camila Orsolon disse...

Nossa, deu muito certo! Obrigadaaa...

Anônimo disse...

Mt Obrigado deu Certo vocês são d+

Alex disse...

Ariana queria te agradecer de coração pela ajuda...
Sem seu blog que é maravilhoso não saberia o que fazer!!
Pois minha esperiência só é com o wp vc me ajudou muito principalmente com o modelo de template que vc sedeu gratuitamente.
Eu não estava conseguindo resolver esse problema acima descrito e mais uma vez vc foi maravilhosa e me ajudou e muitos aqui presentes beijo grande pra vc..
Deus te abençõe muito mesmo.

Historiaplena disse...

Ariane, Creio que vc deve ter lido minha mensagem sobre meu blog (historiaplena.blogspot.com). Uso seu template Oggi. então, o template é ótimo, mas tenho dois problemas. os links anteriores não "consertaram" depois da alterações do post acima e não consigo colocar os 9 posts na primeira página mesmo alterando as configurações em disign. Você pode me ajudar? Não queria abandonar o template, meus alunos gostam muito do blog do jeito que está. obrigado e um grande abraço.

Ariane disse...

Historiaplena eu não tenho como ver, só pelo código fonte, se você fez a alteração corretamente. Quanto ao número de posts, o próprio Blogger impõe um limite de 'peso' para a página inicial. Quando os posts são muito longos ou com muitas imagens, acaba ocorrendo este problema.

Layla Costa disse...

oi Ariane, adoro seu blog e sempre venho aki aproveitar suas dicas e tutoriais, tenho uma dúvida cruel q há dias to tentando esclaracer e nada, coloquei uma imagem de fundo de caderno na minha área de post , mas qnd o texto é muito grande ultrapassa a altuta da imagem e ela repete e aí fika akela kebra feia, eu queria q ela foses contínua e se adequasse ao tamanho do texto sem se repetir. já usei a propriedade background-attachment: fixed mas a imagem ficou desalinhada, tentei alinhar com as propriedades margin e padding e nada. ñ sei mais oq fazer, me ajuda!! de toda forma obrigada!!

Victor P. シ disse...

Oii, meu problema nao é esse, mas e relacionado entao vou comenta aqui mesmo.
Qual é o seu problema victor?
Simples,
Eu Postei 13 postagens no blog, tituladas de 1 a 13.
Cofigurei la em: Configurações > Formatação > Nº de postagens, para 8 no maximo, e tbm fiz isso la em Elementos da página > Editar(no quadrado do post)
Ai na pagina inicial aparece, da 13 a 6 postagem, até aqui tudo certo pois configurei para aparecer 8.
Ai clico em postagens mais antigas, e em vez de aparecer da 8 a 1, so aparece o postagem 1.

Consegue me ajudar?

Espero resposta, vlw

Itiruçu Notícias disse...

Estou querendo usa o Temple oggi mais quando clique no leia mais a coluna da postagem fica embaixo da coluna lateral. O qu eposso fazer? Meu e-mail é grandosneto@msn.com para quem poder me ajudar.
Obrigado

Itiruçu Notícias disse...

Já resolvir o meu problema agora eu gostaria de colocar um link de envio de postagens mais no templates Oggi não aparece o que posso fazer?

Postar um comentário

Os comentários são moderados.